Solved: Unable to get uManage going

Oct 25, 2011 at 8:30 AM
Edited Oct 27, 2011 at 12:05 PM

Hi all,

 

I'm unable to get uManage going on my new Ad environment.

Followed instructions to the letter....

Situation:

1x Win 2k8 R2 x64 - SQL Server 2008 R2 (Standard Edition 64bit Version 10.50.2500.0)

1x Win 2k8 R2 x64 - Web server

2x Win 2k8 R2 x64 - Domain Controllers

Installed IIS7 on web server including .NET 4.0 (http://www.microsoft.com/download/en/details.aspx?id=17718)

Created Application in IIS, with domain admin credentials (testing)

Run Setup ... it halts in uManage Offline after overview screen.

At this time web.config has not been edited at all...

Database is created at SQL server.

When removing page offline file, the wizard starts over...

Now what? Any suggestions?

 

 

I've tried creating everything manually, but no luck either.

 Maybe it's better to wait for next release...?

Oct 27, 2011 at 10:44 AM

Next try,

Completely remove IIS and .NET - restart from scratch.

Installed Application Role - including ASP.net, IIS management and IIS6 (Full)

Created new site with own application pool (umanage) and domain admin user credentials that has acces on ntfs base to the files

Create group Umanage-Users, added domain admin and the application pool user.

Change authentication within iis to windows authentication and removed provider

Create dns entry for site

Then the site kept asking for credentials and ending in access denied.

To fix I had to add registry setting:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0

Add multi-string value with name BackConnectionHostNames and add url to that one

Ran setup wizard... no luck... removed AppOffline file

Imported sql file to db server.

Ran AddUserToRoles.sql (edited because of errors)

DECLARE @RC int
DECLARE @ApplicationName nvarchar(256)
DECLARE @UserNames nvarchar(4000)
DECLARE @RoleNames nvarchar(4000)
DECLARE @CurrentTimeUtc datetime

-- TODO: Specify the user account here
SET @UserNames = N'VIM\administrator'
SET @ApplicationName = N'uManage'
SET @RoleNames = N'Admin,System'
SET @CurrentTimeUtc = GETUTCDATE()

EXECUTE @RC = [uManage-VIM.LOCAL].dbo.Setup_AddUserToRoles
   @ApplicationName
  ,@UserNames
  ,@RoleNames
  ,@CurrentTimeUtc
GO


 Edits to web.config

Line 10: <add name="ADService" connectionString="LDAP://VIM.local" />
Line 11: <add name="uManageEntities" providerName="System.Data.EntityClient" connectionString="metadata=res://*/uManage.csdl|res://*/uManage.ssdl|res://*/uManage.msl;provider=System.Data.SqlClient;provider connection string='Data Source=10.8.20.23;Initial Catalog=uManage-VIM.LOCAL;User ID=ums-conn-vim.local;Password=bladiebla;MultipleActiveResultSets=True;'" />
Line 15: <add key="LaunchSetupWizard" value="false" />
Line 89 and beyond:    
<membership defaultProvider="AspNetActiveDirectoryMembershipProvider">
      <providers>
        <clear/>
        <add connectionStringName="ADService" 
   connectionUsername="VIM\sa_umanage
   connectionPassword="bladiebla"
          enablePasswordReset="true"
    enableSearchMethods="true"
    applicationName="uManage"
          clientSearchTimeout="30" serverSearchTimeout="30" name="AspNetActiveDirectoryMembershipProvider"
          type="System.Web.Security.ActiveDirectoryMembershipProvider, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
      </providers>
    </membership>
   
Line 103 and beyond: <roleManager enabled="true" cacheRolesInCookie="true" cookieName=".uManageRoles"
      cookieTimeout="15" cookiePath="/" cookieSlidingExpiration="true"
      cookieProtection="All" defaultProvider="RoleProvider">

 

Final error:
Now I'm stuck with the following error:

 

Server Error in '/' Application.

The format of the specified domain name is invalid.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.DirectoryServices.ActiveDirectory.ActiveDirectoryOperationException: The format of the specified domain name is invalid.


Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Stack Trace:

[ActiveDirectoryOperationException: The format of the specified domain name is invalid.
]
   System.DirectoryServices.ActiveDirectory.DirectoryContext.GetDnsDomainName(String domainName) +188
   System.DirectoryServices.ActiveDirectory.DirectoryContext.GetLoggedOnDomain() +785
   System.DirectoryServices.ActiveDirectory.DirectoryContext.IsContextValid(DirectoryContext context, DirectoryContextType contextType) +186
   System.DirectoryServices.ActiveDirectory.DirectoryContext.isDomain() +66
   System.DirectoryServices.ActiveDirectory.Domain.GetDomain(DirectoryContext context) +98
   PPI.UMS.AD.PasswordExpires..ctor() +63
   PPI.UMS.AD.User.BuildUserFromPrincipal(UserPrincipal user) +729
   PPI.UMS.Web.App_Master.Admin.Page_Load(Object sender, EventArgs e) +102
   System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +25
   System.Web.UI.Control.LoadRecursive() +116
   System.Web.UI.Control.LoadRecursive() +206
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2750



Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1

Googled EVERYTHING and did not come up with an soluction....

Maybe ASP.NET version trouble?

Oct 31, 2011 at 6:00 PM

Solved using this discussion by GregChapman: http://umanage.codeplex.com/discussions/277766

 

Solution:

That was it!!

I swear to have followed the directions to the letter, but after creating the app pool one must manually change the application identity.

How:
Right clik application pool, set identity as domain\username.

Thanks Greg!