One more step - Connection String configuration

Oct 24, 2011 at 7:21 PM

We are configuring uManage to run on IIS7 in Windows Server 2008 R2 x64 and connecting to another server of similar configuration for DB services. The DB server is also 64 bit and is running SQL 2008 R2. At this point, I haven't found a valid connection string. I've followed the manual setup instructions with no luck. My current string is:
<add name="uManageEntities providerName="System.Data.EntityClient" connectionString="metadata=res://*/uManage.csdl|res://*/uManage.ssdl|res://*/uManage.msl;provider=System.Data.SqlClient;provider connection string='Data Source=My.SQLServer.IP.ADDress;Initial Catalog=uManage-OurADDomain;ID=ums-conn-Name;MultipleActiveResultSets=True'"/>

Could anyone share their currently working connection string for use over a TCP connection?

Thanks

Coordinator
Oct 24, 2011 at 8:43 PM

Greg,

The parameter “ID” is invalid. Are you trying to connect via SQL Authentication or Active Directory Authentication?

For SQL Auth replace ID with the following: “User ID=mySQLuser;Password=itsASecret;”

For Windows Auth replace ID with the following: “Integrated Security=True;”

Let me know if you need more help with this.

Thanks,

Brent

From: GregChapman [email removed]
Sent: Monday, October 24, 2011 2:22 PM
To: bpabst@pabstproductions.com
Subject: One more step - Connection String configuration [umanage:277021]

From: GregChapman

We are configuring uManage to run on IIS7 in Windows Server 2008 R2 x64 and connecting to another server of similar configuration for DB services. The DB server is also 64 bit and is running SQL 2008 R2. At this point, I haven't found a valid connection string. I've followed the manual setup instructions with no luck. My current string is:
<add name="uManageEntities providerName="System.Data.EntityClient" connectionString="metadata=res://*/uManage.csdl|res://*/uManage.ssdl|res://*/uManage.msl;provider=System.Data.SqlClient;provider connection string='Data Source=My.SQLServer.IP.ADDress;Initial Catalog=uManage-OurADDomain;ID=ums-conn-Name;MultipleActiveResultSets=True'"/>

Could anyone share their currently working connection string for use over a TCP connection?

Thanks

Oct 24, 2011 at 9:48 PM

Thanks for the tip. Managed to make that work (had to do some creative account management in SQL studio as well). And now I'm ready to document the next error. When I'm done...I'll be done. ;)

Oct 13, 2012 at 11:53 PM

could you pls guide us to make it success? I have tried many times configuring portal live but failing at Application Offline.