The connection name 'AppService' was not found in the applications configuration or the connection string is empty.

Mar 2, 2011 at 1:08 AM

Hello, I have recently setup the application following the documentation.  After the wizard, the 'application offline' page came up.  I removed that file and now receive the error below:

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: The connection name 'AppService' was not found in the applications configuration or the connection string is empty.

Source Error:

Line 77:         <clear />
Line 78: <add connectionStringName="AppService" applicationName="uManage"
Line 79: name="RoleProvider" type="System.Web.Security.SqlRoleProvider" />
Line 80: </providers>
Line 81: </roleManager>


 

Thank you for any help you can provide.  This really will be an awesome tool for us.

Coordinator
Mar 2, 2011 at 5:46 AM

Most likely the system was unable to install the database portion of the system as it does not seem to have setup all of the settings. Take a look at the manual installation instructions and see if that helps, otherwise let me know and we can try something else.

Brent

Mar 2, 2011 at 1:20 PM

Great, thank you.  I worked that out, but am getting the message below:

 

The format of the specified domain name is invalid.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.DirectoryServices.ActiveDirectory.ActiveDirectoryOperationException: The format of the specified domain name is invalid.


Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Stack Trace:

[ActiveDirectoryOperationException: The format of the specified domain name is invalid.
]
System.DirectoryServices.ActiveDirectory.DirectoryContext.GetDnsDomainName(String domainName) +195
System.DirectoryServices.ActiveDirectory.DirectoryContext.GetLoggedOnDomain() +785
System.DirectoryServices.ActiveDirectory.DirectoryContext.IsContextValid(DirectoryContext context, DirectoryContextType contextType) +186
System.DirectoryServices.ActiveDirectory.DirectoryContext.isDomain() +66
System.DirectoryServices.ActiveDirectory.Domain.GetDomain(DirectoryContext context) +98
PPI.UMS.AD.PasswordExpires..ctor() +63
PPI.UMS.AD.User.BuildUserFromPrincipal(UserPrincipal user) +729
PPI.UMS.Web.App_Master.Admin.Page_Load(Object sender, EventArgs e) +102
System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +25
System.Web.UI.Control.LoadRecursive() +71
System.Web.UI.Control.LoadRecursive() +190
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3048



Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1

 

 

I've tried westfield and westfield.local.  Here is the connection strings section, this is from the beta version I received the same result with 1.2 so I tried 1.21:

 

  <connectionStrings>
    <clear />
    <add name="ADService" connectionString="ldap://westfield.local" />
    <add name="uManageEntities" connectionString="metadata=res://*/uManage.csdl|res://*/uManage.ssdl|res://*/uManage.msl;provider=System.Data.SqlClient;provider connection string='Data Source=wfs2\umanage;Initial Catalog=uManage-WESTFIELD;User ID=ums-conn-westfield;Password=&quot;&amp;@(tr0!O-kEDqbqtZ#&gt;(3xirtV8^j.v;zH.bl!m4u@s0OMgFuLe{o=QG}VHo+{s[&quot;;MultipleActiveResultSets=True'"
      providerName="System.Data.EntityClient" />
  </connectionStrings>

 

BTW, nice name :)

 

-Brent

Coordinator
Mar 2, 2011 at 6:36 PM

Make sure LDAP:// is in all caps and then try again.

Brent

Oct 14, 2011 at 7:04 PM

I will try this:

"IIS 7 does not install an ADSI provider by default.  You can enable it however as a Role Service for the IIS Web Server.  You need to enable the IIS 6 Metabase Compatiblity role service."
 
It wasn't until I looked closer at the new Server 2008 64bit box that I saw the IIS6 stuff had not been installed -- I didn't load the box.  Then I went back and looked at our other 32bit boxes running IIS7 and they *did* have all the IIS6 stuff installed.
 
But then we faced the issue of how to determine if this component was installed or not, as our app could be run on a box thay may or may not have it ... and apparently it is needed.
 
So, a little bit of searching around and I was able to locate this article which seems to have answered that question as well:
http://learn.iis.net/page.aspx/135/discover-installed-components

Ps.: Windows Server 2008 R2

Oct 15, 2011 at 3:26 PM

I am using a Windows Server 2008 R2 with IIS 7.5. The IIS 7.5 have new features when Windows Authentication is enable.

This worked for me:

On IIS Manager > MyWebSite > Authentication > Windows Authentication > Right Menu, click in Providers, enable only Negotiate (remove NTLM).

--

Alexandre Smialoski

Oct 15, 2011 at 6:41 PM

I changed the provider for only NTLM, and it worked well.

I think the problem occurs when the 2 providers are enabled.
Oct 25, 2011 at 7:49 PM

I reopen this post because I have a similar problem.

I'm trying to get v1.2.1 running on a Windows Server 2008 R2. I completed the installtion (with several tries). Now, I'm getting the error:

The format of the specified domain name is invalid.

Mit web.config Key: <add name="ADService" connectionString="LDAP://trillian.kfk.local" /> looks correct. I also tried the Authentication Provider to Negotiae without luck.

Any idea?

Oct 25, 2011 at 11:25 PM

My results match zueri's . Changing which providers were available, their order and auth isolation in IIS 7 did not correct this issue. So far, from what I'm seeing it appears that 64 bit 2008 R2 seems to be a variable we all have in common.

Oct 27, 2011 at 8:13 AM

After numerous tries my results also match zueri's.