Not installing

Jul 14, 2010 at 12:16 AM
This looks really from the website, but I cannot get it to install using the wizard. I'm stuck at the wizard page where is prompts to automatically configure the Database. I keep getting this error: Failed to Connect to the Database Server uManage was unable to either connect to the database server or validate the SA credentials specified are allowed to perform the required actions. Verify the server is online and available and that you specified the correct credentials. I'm using server 2008 R2, and SQL Express 2008. Any suggestions would be helpful. Thank you
Coordinator
Jul 14, 2010 at 3:06 AM
Edited Jul 14, 2010 at 3:07 AM

Hi,

 

Have you ensured you can already connect to the database server using SQL Management Studio with the SA username and password?  This error is usually network or credential related since it is coming directly from the .NET framework.  If you cannot access the server with management studio you can try the following:

 

1. Enable TCP/IP (it is disabled by default)

2. Ensure the local or server firewall is not blocking the connection. Port 1433 needs to be open in most cases unless you used a different port.

 

Let me know if any of that works for you.

 

Brent

 

Jul 14, 2010 at 7:24 AM

Hi,

Also make sure you have enabled the SA account in SQL - this is disabled if you selected 'Windows Authentication Mode' during the SQL installation. uManage needs a SQL account (*not a Windows account with SQL permissions).

This is what tripped me up at first, until I realized :)

Geoff

Coordinator
Jul 14, 2010 at 12:28 PM

@muppetgeoff You can use Windows Auth, its just that the Installer does not set it up for you.  You can manually install the application if you want to use Windows Auth.  The instructions are provided for that method as well.

Jul 17, 2010 at 4:39 AM

I'm sorry, I'm really knew to using MSSQL and asp.net

I found where to change the authentication to use both Windows authentication and sql authentication.

I still got the error.

 

In the form when it said server address I had entered the ip address of the server.

Then I changed that entry to server\sql instance.  For me it is Win2k8-1\sqlexpress

It now finished the wizard.

 

Then it loaded the offline webpage.

so I rename that page, and now I get this error:

 

Configuration Error

<!-- body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;} p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px} b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px} H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red } H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon } pre {font-family:"Lucida Console";font-size: .9em} .marker {font-weight: bold; color: black;text-decoration: none;} .version {color: gray;} .error {margin-bottom: 10px;} .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; } -->

Server Error in '/' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: The connection name 'AppService' was not found in the applications configuration or the connection string is empty.

Source Error:

Line 73:       <providers>
Line 74:         <clear />
Line 75:         <add connectionStringName="AppService" applicationName="uManage" name="RoleProvider" type="System.Web.Security.SqlRoleProvider" />
Line 76:       </providers>
Line 77:     </roleManager>


Source File: D:\uManage\web.config    Line: 75

 

I did go into SQL Management Studio, and I do see the database created.

I also recycled the application.

 

Anyone have any clues

 

Coordinator
Jul 17, 2010 at 4:02 PM

acraiger,

The Application Offline page currently will only be displayed in the event that the installer fails to do something with the database.  The error you provided tells me that the connection string for the applications which is usually configured by the application is set around the 15th line of the configuration file is blank.  This leads me to suspect that the database, even though created, actually does not have any tables inside of it.  Please verify that the tables have not been created inside of the table.  If they have not do the following:

1. Delete the database all together.  If the database already exists the auto-installer will not be able to re-create it.

2. Delete the user in the database server's Security->Login area.  It should be titled "ums-conn".

3. Reset the application code, the easiest way to do this is to simply overwrite the web application directory with the program you downloaded from CodePlex.

4. Re-run the application and the auto-installer.  It should all work correctly now that your database server is ready to go.

This problem is caused whenever the database installation fails.  In your case since the database was created I would imagine the process failes because the user account already existed and the system will fail if it cannot create the user account.

Hopefully this works for you.

Jul 28, 2010 at 5:59 AM
This did not work. The account ums-conn was never created in sql. I've tried the manual instructions, but I get completely lost following the instructions. They seem very incomplete for someone who's never worked with mssql. It says navigate to a sql file, so what then.
Coordinator
Aug 2, 2010 at 3:20 PM
acraiger wrote:
This did not work. The account ums-conn was never created in sql. I've tried the manual instructions, but I get completely lost following the instructions. They seem very incomplete for someone who's never worked with mssql. It says navigate to a sql file, so what then.

Unfortunately working with Active Directory and MSSQL are pretty complex all around, not for the faint of heart thats for sure.  The point in the instructions is to open the SQL file and execute it against your database.  It sets up all of the tables and values that are required.  There is also another SQL file which you can download from the Instructions/Documentation thread which helps when making a user an admin user.

The instructions expect someone to have a basic understanding of MSSQL server and Management Studio, if you need help with using either I would suggest reviewing the Microsoft documentation at both MSDN and TechNet for detailed instructions.  There is too much to cover in a simple set of instructions for this application.

Let me know if you still get stuck or cannot get the SQL file to execute properly and we can take it from there.

Aug 5, 2010 at 1:22 PM

Guys help please. I am getting this error:

Unknown error (0x80005000)

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.Runtime.InteropServices.COMException: Unknown error (0x80005000)

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Stack Trace: 

[COMException (0x80005000): Unknown error (0x80005000)]
   System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail) +420085
   System.DirectoryServices.DirectoryEntry.Bind() +36
   System.DirectoryServices.DirectoryEntry.get_AdsObject() +31
   System.DirectoryServices.PropertyValueCollection.PopulateList() +26
   System.DirectoryServices.PropertyValueCollection..ctor(DirectoryEntry entry, String propertyName) +49
   System.DirectoryServices.PropertyCollection.get_Item(String propertyName) +141
   System.DirectoryServices.AccountManagement.PrincipalContext.DoLDAPDirectoryInitNoContainer() +298
   System.DirectoryServices.AccountManagement.PrincipalContext.DoDomainInit() +37
   System.DirectoryServices.AccountManagement.PrincipalContext.Initialize() +124
   System.DirectoryServices.AccountManagement.PrincipalContext.get_QueryCtx() +31
   System.DirectoryServices.AccountManagement.Principal.FindByIdentityWithTypeHelper(PrincipalContext context, Type principalType, Nullable`1 identityType, String identityValue, DateTime refDate) +14
   System.DirectoryServices.AccountManagement.Principal.FindByIdentityWithType(PrincipalContext context, Type principalType, String identityValue) +73
   System.DirectoryServices.AccountManagement.UserPrincipal.FindByIdentity(PrincipalContext context, String identityValue) +25
   PPI.UMS.AD.User..ctor(String Username) +195
   PPI.UMS.Web.Forms.Users.User_Info.Page_Load(Object sender, EventArgs e) +67
   System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14
   System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +35
   System.Web.UI.Control.OnLoad(EventArgs e) +91
   System.Web.UI.Control.LoadRecursive() +74
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2207



Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1

 

 

Aug 5, 2010 at 2:05 PM

@vzarate:  http://support.microsoft.com/kb/329986

Coordinator
Aug 5, 2010 at 2:09 PM

Just a request, but please create a new discussion thread for any new problems.  That way everyone has the proper chance to get help.

Thanks